當前位置: 主頁 > 百科 > 計算機編程 > 易語言源碼 >
0 Comments

取本機機器碼

發布于:2016-07-05  |   作者:http://www.tradlc.live  |   已聚集:人圍觀

.版本 2

.支持庫 eAPI

.程序集變量 網卡地址, 網卡信息, , "0"

.程序集變量 網卡mac, 文本型

.程序集變量 CPU信息, CPU信息

.程序集變量 CPU, 文本型

.程序集變量 大寫字母, 文本型, , "26"

.程序集變量 小寫字母, 文本型, , "26"

.程序集變量 數字, 文本型, , "26"


.子程序 __啟動窗口_創建完畢


取機器碼 ()


.子程序 取機器碼

.局部變量 輸入內容, 文本型

.局部變量 輸出內容, 文本型

.局部變量 文本長度, 整數型

.局部變量 i, 整數型

.局部變量 臨時變量I, 整數型

.局部變量 臨時變量J, 整數型

.局部變量 轉換后文本, 文本型

.局部變量 臨時, 字節集

.局部變量 計次, 整數型


數字 = { “1”, “2”, “3”, “4”, “5”, “6”, “7”, “8”, “9”, “10”, “11”, “12”, “13”, “14”, “15”, “16”, “17”, “18”, “19”, “20”, “21”, “22”, “23”, “24”, “25”, “26” }

大寫字母 = { “A”, “B”, “C”, “D”, “E”, “F”, “G”, “H”, “I”, “J”, “K”, “L”, “M”, “N”, “O”, “P”, “Q”, “R”, “S”, “T”, “U”, “V”, “W”, “X”, “Y”, “Z” }

小寫字母 = { “a”, “b”, “c”, “d”, “e”, “f”, “g”, “h”, “i”, “j”, “k”, “l”, “m”, “n”, “o”, “p”, “q”, “r”, “s”, “t”, “u”, “v”, “w”, “x”, “y”, “z” }

取CPU信息 (CPU信息)

CPU = 取文本左邊 (CPU信息.序列號, 18)

網卡地址 = 取網卡信息列表 ()

.判斷開始 (取數組成員數 (網卡地址) ≥ 1)

    網卡mac = 網卡地址 [1].物理地址

.默認

    網卡mac = “10-11-11-11-11-11”

.判斷結束

.如果 (選擇框1.選中 = 真)

    編輯框1.內容 = 子文本替換 (網卡mac, “-”, “”, , , 真) + 子文本替換 (CPU, “-”, “”, , , 真)

.否則

    輸入內容 = 子文本替換 (網卡mac, “-”, “”, , , 真) + 子文本替換 (CPU, “-”, “”, , , 真)

    文本長度 = 取文本長度 (輸入內容)

    .計次循環首 (文本長度, i)

        轉換后文本 = 取文本中間 (輸入內容, i, 1)

        .如果真 (轉換后文本 ≥ “A” 且 轉換后文本 ≤ “Z” 或 轉換后文本 ≥ “a” 且 轉換后文本 ≤ “z”)

            轉換后文本 = “”

        .如果真結束

        輸出內容 = 輸出內容 + 轉換后文本

    .計次循環尾 ()

    編輯框1.內容 = 輸出內容

    .計次循環首 (取文本長度 (輸入內容), 臨時變量I)

        .計次循環首 (取數組成員數 (大寫字母), 臨時變量J)

            .如果真 (取文本中間 (輸入內容, 臨時變量I, 1) = 大寫字母 [臨時變量J] 或 取文本中間 (輸入內容, 臨時變量I, 1) = 小寫字母 [臨時變量J])

                編輯框1.加入文本 (數字 [臨時變量J])

            .如果真結束


        .計次循環尾 ()

    .計次循環尾 ()

.如果結束

.如果 (選擇框3.選中 = 真)

    臨時 = 到字節集 (子文本替換 (網卡mac, “-”, “”, , , 真) + 子文本替換 (CPU, “-”, “”, , , 真))

    .計次循環首 (取字節集長度 (臨時), 計次)

        .如果真 (臨時 [計次] ≠ 45 且 臨時 [計次] < 48 或 臨時 [計次] > 57)

            到循環尾 ()

        .如果真結束

        .如果真 (臨時 [計次] = 48)

            臨時 [計次] = 74

            到循環尾 ()

        .如果真結束

        .如果真 (臨時 [計次] = 45)

            臨時 [計次] = 77

            到循環尾 ()

        .如果真結束

        臨時 [計次] = 臨時 [計次] + 16

    .計次循環尾 ()

    編輯框1.內容 = 到文本 (臨時)

.否則


.如果結束

.子程序 _選擇框1_被單擊


選擇框1.選中 = 真

選擇框2.選中 = 假

選擇框3.選中 = 假

取機器碼 ()


.子程序 _選擇框2_被單擊


選擇框1.選中 = 假

選擇框2.選中 = 真

選擇框3.選中 = 假

取機器碼 ()



.子程序 _選擇框3_被單擊


選擇框1.選中 = 假

選擇框2.選中 = 假

選擇框3.選中 = 真

取機器碼 ()


標簽:                   喜歡:收藏
2019年马会全年资料